刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版

频道:欧洲联赛 日期: 浏览:266

出自大众号123118:豁然IT杂谈

VLAN Mapping原理介绍

​VLAN技能的运用能有用的操控播送域规模、阻隔用户。可是由于一些低端交流机不支持VLAN ID为1~4094整个规模,而是相似苏乔顾庭深1~512的有限规模,一些VLAN ID被保存,用户自行规划VLAN ID导致与公网VLAN ID抵触。因而VLAN Mapping技能应运而生。

VLAN Mapping,也叫做VLAN T千秋门ranslation或VLAN映射,它经过替换数据帧中的内外层VLAN Tag来完成用户VLAN与运营商VLAN的彼此映射,运用户事务依照运营商的网络规划进行传输。

VLAN Mapping发生在报文从入接口接纳进来之后,从出接口转发出去之前。在交流机的内部会保护一张VLAN映射表,依据映循化气候射表进行映射操作。

交流机收到数据报文后,依据是否带有Tag做以下两种处理:

数据报文带Tag,依据装备的VLAN Mapping方法,决议替换单层、双层或双层中的外层Tag;然后进入MAC地址学习阶段,依据源MAC地址+映射后的VLAN ID改写MAC地址表项;依据意图MAC+映射后VLAN ID查找MAC地址表项,假如没有找到,则在VLAN ID对应的VLAN内播送,不然从表项对应的接口转发。

数据报文不带Tag,依据装备的VLAN区分方法决议是否增加VLAN Tag,关于不能参加VLAN的数据报文上送CPU或丢掉,不然增加Tag;然后进入MAC地址学习阶段,依照二层转发流程进行转发。

此外,要想凭借VLAN Mapping完成两个VLAN内设备彼此通讯,这两个VLAN内设备的IP地址还有必要处于同一网段。假如两个VLAN内设备的IP地址不在同一网段,那么设备间的互通需求依靠三层路由完成,这样就失去了VLAN Mapping的含义。

映射方法

1)1 to 1的映射方法

当布置VLAN Mapping功用设备上的主接口收到带有单层VLAN Tag的报文时,将报文中带着的单层VLAN Tag映射为公网的VLAN Tag。

2)N to 1的映射方法

将多个用户侧VLAN Tag标签映射到一个网络侧VLAN Tag标签。

3)2 to 1的映射方法

当布置VLAN Mapping功用设备上的主接口收到带有双层VLAN Tag的报文时,将报文中带着的王俊凯的老婆外层Tag映射为公网的Tag,内层Tag作为数据透传。

4) 2 to 2的映射方法

当布置VLAN Mapping功用设备上的主接口收到天鼎元素服带有双层VLAN Tag的报文时,将报文中带着的双层VLAN Tag映射为公网的双层VLAN Tag。

VLAN映射试验

试验拓扑

1 to 1的映射方法

试验布景:

不同的小区具有相同的事务,各个小区将不同的事务区分到不同的VLAN中,相同的事务区分到同一个VLAN中。由于各小区网络管理员事前没有洽谈好,存在不同的小区中相同的事务所属的VLAN不相同,要完成相同事务、不同VLAN间的延寿县青川乡用户彼此通讯。如小区A和小区B中具有相同的事务,可是归于不同的VLAN(即VLAN 10和VLAN 20,但这车虫小宋电视剧全集两个VLAN中的用户计算机同处一个IP网段中)。要完成经过VLAN映射功用完成小区A和小区B的用户可以直接互通。

试验思路:

在交流机sw1上创立相应的VLAN,把接口GE0/0/1改为Trunk端口并答应VLAN 20的流量经过,启用VLAN标签的转化,把刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版VLAN 10王鸿翔墨梅的转化为VLAN 20,然后把GE0/0/2接口改为Trunk并答应VLAN 20的流量经过,交流机sw2同理。

试验过程:

1.装备2台PC的IP地址,子网掩码。

2.在交流机刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版sw1上创立VLAN 10与VLAN 20,将接口GE0/0/1改为Trunk端口,并答应VLAN 20的流量经过,启用vlan标签的转化,将vlan标签10转化成20,转化后才往上发送信息。

system-view

sysname sw1

vlan batch 10 20

interface GigabitEthernet 0/0/1

port link-type trunk

port trunk allow-pass vlan 20

qinq vlan-translation enable

port vlan-mapping vlan 10 map-vlan 20

quit

3.将交流机sw1的GE0/0/2接口改为Trunk端口,并答应VLAN 20的流量经过。

interface GigabitEthernet 0/0/2

port link-type trunk

port trunk allow-pass刀神天后 vlan 20

quit

4.在交流机sw2上创立VLAN 10与VLAN 20,将接口GE0/0/2改为Trunk端口,并答应VLAN 10的流量经过,启用vlan标签的转化,将vlan标签20转化成10,转化后才往上发送信息。

system-view

sysname sw2

vlan batch 10 20

interface GigabitEthernet 0/0/2

port link-t挨揍受罚ype trunk

port trunk allow-pass vlan 10

qinq vlan-translation enable

port vlan-mapping vlan 20 map-vlan 10

quit

5.将交流机sw2的GE0/0/1接口改为Trunk端口,并答应VLAN 10的流量经过潘晓婷的老公。

interface GigabitEthernet 0/0/1

port link-type trunk

p刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版ort trunk allow-经略盛唐pass vlan 10

quit

试验结打边炉资料清单果:

试验拓扑

n to 1的映射方法

试验过程:

1.装备2台PC的IP地址,子网掩码。

2.在交流机sw1上创立VLAN 10、20、30,将接口GE0/0/1参加vlan 10,将接口GE0/0/2参加vlan 20,

system-view

sysname sw1

vlan batch 10 20 30

in老婆太惹火t刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版erface Gig刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版abitEthernet0/0/1

port link-type access

port default vlan 10

interface GigabitEthernet0/0/2

port link-type access

port default vlan 20

interface GigabitEthernet0/0/3

port link-type access

port default vlan 30

interface GigabitEthernet0/0/24

port link-type trunk

port trunk allow-pass vlan 10 20 30

3.将交流机sw2的GE0/0/2接口参加vlan40,将接口GE0/0/24设置为Hybird,并答应带有标签 的VLANID 为10,20,30刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版,40 的数据帧经过,运用VLAN MAPPING的接口的数据帧有必要 是得带标签的

system-view

sysname sw2

vlan batch 10 20 30 40

interface GigabitEthernet0/0/1

port link-type access

port default vlan 40

interface GigabitEth刘兰芳,瑞贝卡,龙抬头-雷竞技安卓_雷竞技安卓版_雷竞技官方app下载安卓版ernet0/0/24

qinq vlan-translation enable

port hybrid tagged vlan 10 20 30 40

port vlan-mapping vlan 10 map-vlan 40

port vlan-mapping vlan 20 map-vlan 40

port vlan-mapping vlan 30 map-vlan 40

试验成果:

1)

PC1->PC4ping 通

PC2->PCdangours4ping 通

PC3->PC4ping 通

2)

PC4->PC1ping 通

PC4->PC2ping 通

PC4->PC3ping 通

3)

PC1->PC2ping 不通

PC1->PC3ping 不通

PC2->PC3ping 不通

阐明:

1)PC1,PC2,PC3的数据帧交流主要是在SW1中,由于的他们的VLAN ID不同,区分了播送域,尽管地址段都是192.168.1.0 /24,可是不可以互杭州气候24小时相ping通;

2)PC1/PC牛生殖器2/PC3与PC4可以ping通,是由于在SW2进行数据帧交流的时分,进行了VLAN MA绿酷高PPING的处理,运用N对1的方法把VLAN ID 10,20,30悉数映射为VLAN ID 40,处于同一个播送域,所以可以彼此ping通。